Bardzo rozbudowana formuła

Najbardziej skomplikowana formuła jaką napisałem w MS Excel. Pomińmy milczeniem do czego służy i co robi 🙂 W sumie taka sztuka dla sztuki : {=JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))>=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));LEWY(A2;DŁ(A2)-2)&PRAWY(A2;2)+1;LEWY(A2;DŁ(A2)-2-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))))&PRAWY(LEWY(A2;DŁ(A2)-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))));2)+1);A2&”.10″)}

Najbardziej skomplikowana formuła jaką napisałem w MS Excel. Pomińmy milczeniem do czego służy i co robi 🙂
W sumie taka sztuka dla sztuki :

{=JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))>=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));LEWY(A2;DŁ(A2)-2)&PRAWY(A2;2)+1;LEWY(A2;DŁ(A2)-2-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))))&PRAWY(LEWY(A2;DŁ(A2)-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))));2)+1);A2&”.10″)}