Libre Office Calc – Formuły i funkcje, Adresowanie typu A1

  Formuły i funkcje Formułę zawsze rozpoczynamy od znaku [=] Przykłady: =2+2 (dodawanie) =2*2 (mnożenie) =2/2 (dzielenie) Po zatwierdzeniu formuły w aktywnej komórce pojawia się jej wynik. Możliwe do wykorzystania […]

 

Formuły i funkcje

Formułę zawsze rozpoczynamy od znaku [=]

Przykłady: =2+2 (dodawanie) =2*2 (mnożenie) =2/2 (dzielenie)

Po zatwierdzeniu formuły w aktywnej komórce pojawia się jej wynik.

Możliwe do wykorzystania operatory: [+], [-] , [-] (jako negacja), [*], [/] (dzielenie), [^] (potęgowanie), [%] (procent)
Oraz operatory porównań: [=], [>], [>=], [<], [<=], [<>] (odpowiednio: równe, większe, większe lub równe, mniejsze, mniejsze lub równe, różne)

Budowa funkcji: NAZWA_FUNKCJI(argument/y)
Przykład: =SUMA(B2:B5)

Jeśli funkcja ma więcej niż jeden argument to oddzielamy je średnikami.

Przykłady różnych rodzajów argumentów funkcji:

- liczby =SUMA(10;10) (wynik 20)
- łańcuchy tekstowe =LEWY(„dom”;1) (wynik „d”)
- odwołania do komórek pojedynczych =SUMA(A1;A2)
- odwołania do zakresów komórek =SUMA(A1:A10)
- formuły i funkcje =JEŻELI(LICZ.PUSTE(A1:A5)>0;”WYPEŁNIJ!”;””)
- wartości błędów =CZY.BŁĄD(1/0) (wynik „PRAWDA”, gdyż nastąpiło dzielenie przez 0)
- wartości logiczne =NIE(prawda) (wynik „FAŁSZ”)
- nic =DZIŚ() =TERAZ() =LOS()

 

Adresowanie typu A1

W LibO Calc kolumny oznaczone są kolejnymi literami alfabetu, a następnie dwu- i trzy-literowymi kombinacjami, wiersze oznaczane są kolejnymi liczbami, w konsekwencji każda komórka w arkuszu posiada swój własny unikalny adres, który jest kombinacją oznaczenia kolumny i wiersza.

Możliwe warianty adresowania typu A1 na przykładzie formuły z funkcją SUMA:
=SUMA(A1;A10) – sumuje wartość dwóch komórek o adresach A1 i A10,
=SUMA(A1:A10) – sumuje wszystkie komórki od A1 do A10,
=SUMA(A1:A10;B12) – sumuje komórki od A1 do A10 i dodatkowo pojedynczą komórkę B12,
=SUMA(A:A) – sumuje wszystkie wartości z wszystkich komórek w kolumnie A,
=SUMA(A:D) – sumuje wszystkie wartości z wszystkich komórek w kolumnach od A do D,
=SUMA(1:1) – sumuje wszystkie wartości z wszystkich komórek w wierszu 1,
=SUMA(1:4) – sumuje wszystkie wartości z wszystkich komórek w wierszach od 1 do 4,
=SUMA(1:4;B12) – sumuje wszystkie wartości z wszystkich komórek w wierszach od 1 do 4 oraz dodatkowo zawartość pojedynczej komórki B12.