O Autorze: Marcin Opinc

Strona
http://www.itrain.pl
Opis
Marcin Opinc - trener i pasjonat arkusza kalkulacyjnego MS Excel. Absolwent Politechniki Gdańskiej, Polsko-Japońskiej Wyższej Szkoły Technik Komputerowych w Warszawie oraz Wyższej Szkoły Bankowej w Gdańsku. Zaawansowany, długoletni użytkownik arkusza kalkulacyjnego, a jednocześnie główny trener w firmie szkoleniowej IT & Training.

Posty użytkownika Marcin Opinc

  •   Formuły i funkcje Formułę zawsze rozpoczynamy od znaku [=] Przykłady: =2+2 (dodawanie) =2*2 (mnożenie) =2/2 (dzielenie) Po zatwierdzeniu formuły w aktywnej komórce pojawia się jej wynik. Możliwe do wykorzystania […]

    Libre Office Calc – Formuły i funkcje, Adresowanie typu A1

      Formuły i funkcje Formułę zawsze rozpoczynamy od znaku [=] Przykłady: =2+2 (dodawanie) =2*2 (mnożenie) =2/2 (dzielenie) Po zatwierdzeniu formuły w aktywnej komórce pojawia się jej wynik. Możliwe do wykorzystania […]

    Czytaj dalej...

  •   1. Różne rodzaje danych Rodzaje danych, które możemy wprowadzać i przechowywać w arkuszu LO Calc: – tekst, – liczby (również procenty, ułamki), – daty (właściwie traktowane przez Calc jako […]

    Libre Office Calc – rodzaje i serie danych

      1. Różne rodzaje danych Rodzaje danych, które możemy wprowadzać i przechowywać w arkuszu LO Calc: – tekst, – liczby (również procenty, ułamki), – daty (właściwie traktowane przez Calc jako […]

    Czytaj dalej...

  •   Zaczynamy dziś nowy cykl artykułów dotyczących Libre Office. Całość będzie obejmowała materiał podstawowego szkolenia z używania edytora tekstu – Writer oraz arkusza kalkulacyjnego – Calc. Jeżeli ktoś będzie zainteresowany […]

    Kurs Libre Office – Wprowadzenie

      Zaczynamy dziś nowy cykl artykułów dotyczących Libre Office. Całość będzie obejmowała materiał podstawowego szkolenia z używania edytora tekstu – Writer oraz arkusza kalkulacyjnego – Calc. Jeżeli ktoś będzie zainteresowany […]

    Czytaj dalej...

  • Otóż to. To już rok prac nad systemem gry fabularnej dla działów IT. Rozgrywkę przeprowadzać można codziennie, nie jest uciążliwa w ciągu dnia pracy, a na pewno bardzo ją urozmaica, […]

    Fabularny system gry dla działów IT „Skrętkom i bitem”

    Otóż to. To już rok prac nad systemem gry fabularnej dla działów IT. Rozgrywkę przeprowadzać można codziennie, nie jest uciążliwa w ciągu dnia pracy, a na pewno bardzo ją urozmaica, […]

    Czytaj dalej...

  • WSTĘP Jakiś czas temu opublikowałem na łamach Starych Lam opracowaną przeze mnie metodę przeliczania dnia tygodnia dowolnej daty w pamięci (przy odpowiednim treningu w całkiem sensownym czasie). Artykuł ten był […]

    Obliczanie dnia tygodnia dowolnej daty w pamięci (wersja skrócona)

    WSTĘP Jakiś czas temu opublikowałem na łamach Starych Lam opracowaną przeze mnie metodę przeliczania dnia tygodnia dowolnej daty w pamięci (przy odpowiednim treningu w całkiem sensownym czasie). Artykuł ten był […]

    Czytaj dalej...

  • Najbardziej skomplikowana formuła jaką napisałem w MS Excel. Pomińmy milczeniem do czego służy i co robi 🙂 W sumie taka sztuka dla sztuki : {=JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))>=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));LEWY(A2;DŁ(A2)-2)&PRAWY(A2;2)+1;LEWY(A2;DŁ(A2)-2-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))))&PRAWY(LEWY(A2;DŁ(A2)-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))));2)+1);A2&”.10″)}

    Bardzo rozbudowana formuła

    Najbardziej skomplikowana formuła jaką napisałem w MS Excel. Pomińmy milczeniem do czego służy i co robi 🙂 W sumie taka sztuka dla sztuki : {=JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))>=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));LEWY(A2;DŁ(A2)-2)&PRAWY(A2;2)+1;LEWY(A2;DŁ(A2)-2-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))))&PRAWY(LEWY(A2;DŁ(A2)-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))));2)+1);A2&”.10″)}

    Czytaj dalej...

  • Gdy tekst na którym operujemy objęty jest cudzysłowem, a musimy go wpisać literalnie w treść formuły MS Excel to używamy trzech cudzysłowów (z dwoma nie zadziała): Przykład =Z.WIELKIEJ.LITERY(„””władca pierścieni”””)  Efektem […]

    Cudzysłów w cudzysłowie w Excel

    Gdy tekst na którym operujemy objęty jest cudzysłowem, a musimy go wpisać literalnie w treść formuły MS Excel to używamy trzech cudzysłowów (z dwoma nie zadziała): Przykład =Z.WIELKIEJ.LITERY(„””władca pierścieni”””)  Efektem […]

    Czytaj dalej...

  • Niezależnie od kształtu i wielkości zaznaczenia, zawsze tylko jedna komórka jest w zaznaczeniu komórką aktywną. W poniższym przykładzie komórką aktywną jest komórka A1 (jaśniejsza komórka w lewym górnym rogu zaznaczenia): […]

    Zmiana komórki aktywnej w zaznaczonym zakresie MS Excel

    Niezależnie od kształtu i wielkości zaznaczenia, zawsze tylko jedna komórka jest w zaznaczeniu komórką aktywną. W poniższym przykładzie komórką aktywną jest komórka A1 (jaśniejsza komórka w lewym górnym rogu zaznaczenia): […]

    Czytaj dalej...

  • Próbując wprowadzać do Excela ułamki bezpośrednio w postaci zwykłej np. 1/2 natykamy się na problem – arkusz automatycznie interpretuje taki zapis jako datę („02-sty”). Możemy tego uniknąć poprzedzając ułamek (mniejszy […]

    Ułamki zwykłe w MS Excel

    Próbując wprowadzać do Excela ułamki bezpośrednio w postaci zwykłej np. 1/2 natykamy się na problem – arkusz automatycznie interpretuje taki zapis jako datę („02-sty”). Możemy tego uniknąć poprzedzając ułamek (mniejszy […]

    Czytaj dalej...

  • WSTĘP Możliwość określania dnia tygodnia dla dowolnej daty oferują tzw. kalendarze wieczne, jednak szukanie dnia tygodnia w różnej maści tabelach nie może się równać z liczeniem tego w pamięci (większa […]

    Obliczanie dnia tygodnia dowolnej daty w pamięci (czyli jak zdobyć sprawność Pana Kalendarza)

    WSTĘP Możliwość określania dnia tygodnia dla dowolnej daty oferują tzw. kalendarze wieczne, jednak szukanie dnia tygodnia w różnej maści tabelach nie może się równać z liczeniem tego w pamięci (większa […]

    Czytaj dalej...