Excel Archiwum

  • Formatowanie warunkowe to mechanizm umożliwiający wyróżnianie komórek w arkuszu kalkulacyjnym na podstawie ich wartości. Od wersji 2007 MS Excel wprowadza wiele nowych możliwości prostego formatowania warunkowego bezpośrednio z rozwijanego menu […]

    Proste formatowanie warunkowe w MS Excel

    Formatowanie warunkowe to mechanizm umożliwiający wyróżnianie komórek w arkuszu kalkulacyjnym na podstawie ich wartości. Od wersji 2007 MS Excel wprowadza wiele nowych możliwości prostego formatowania warunkowego bezpośrednio z rozwijanego menu […]

    Czytaj dalej...

  • Najbardziej skomplikowana formuła jaką napisałem w MS Excel. Pomińmy milczeniem do czego służy i co robi 🙂 W sumie taka sztuka dla sztuki : {=JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))>=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));LEWY(A2;DŁ(A2)-2)&PRAWY(A2;2)+1;LEWY(A2;DŁ(A2)-2-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))))&PRAWY(LEWY(A2;DŁ(A2)-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))));2)+1);A2&”.10″)}

    Bardzo rozbudowana formuła

    Najbardziej skomplikowana formuła jaką napisałem w MS Excel. Pomińmy milczeniem do czego służy i co robi 🙂 W sumie taka sztuka dla sztuki : {=JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))>=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));JEŻELI(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))=SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())));LEWY(A2;DŁ(A2)-2)&PRAWY(A2;2)+1;LEWY(A2;DŁ(A2)-2-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))))&PRAWY(LEWY(A2;DŁ(A2)-3*(SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()-1):ADR.POŚR(„AA”&WIERSZ()-1)))-SUMA(CZY.TEKST(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ()))*NR.KOLUMNY(ADR.POŚR(„c”&WIERSZ()):ADR.POŚR(„AA”&WIERSZ())))));2)+1);A2&”.10″)}

    Czytaj dalej...

  • Gdy tekst na którym operujemy objęty jest cudzysłowem, a musimy go wpisać literalnie w treść formuły MS Excel to używamy trzech cudzysłowów (z dwoma nie zadziała): Przykład =Z.WIELKIEJ.LITERY(„””władca pierścieni”””)  Efektem […]

    Cudzysłów w cudzysłowie w Excel

    Gdy tekst na którym operujemy objęty jest cudzysłowem, a musimy go wpisać literalnie w treść formuły MS Excel to używamy trzech cudzysłowów (z dwoma nie zadziała): Przykład =Z.WIELKIEJ.LITERY(„””władca pierścieni”””)  Efektem […]

    Czytaj dalej...

  • Niezależnie od kształtu i wielkości zaznaczenia, zawsze tylko jedna komórka jest w zaznaczeniu komórką aktywną. W poniższym przykładzie komórką aktywną jest komórka A1 (jaśniejsza komórka w lewym górnym rogu zaznaczenia): […]

    Zmiana komórki aktywnej w zaznaczonym zakresie MS Excel

    Niezależnie od kształtu i wielkości zaznaczenia, zawsze tylko jedna komórka jest w zaznaczeniu komórką aktywną. W poniższym przykładzie komórką aktywną jest komórka A1 (jaśniejsza komórka w lewym górnym rogu zaznaczenia): […]

    Czytaj dalej...

  • Próbując wprowadzać do Excela ułamki bezpośrednio w postaci zwykłej np. 1/2 natykamy się na problem – arkusz automatycznie interpretuje taki zapis jako datę („02-sty”). Możemy tego uniknąć poprzedzając ułamek (mniejszy […]

    Ułamki zwykłe w MS Excel

    Próbując wprowadzać do Excela ułamki bezpośrednio w postaci zwykłej np. 1/2 natykamy się na problem – arkusz automatycznie interpretuje taki zapis jako datę („02-sty”). Możemy tego uniknąć poprzedzając ułamek (mniejszy […]

    Czytaj dalej...

  • Arkusz kalkulacyjne MS Excel oferuje nam szeroką gamę wbudowanych formatów standardowych takich jak: liczbowe, walutowe, księgowe, daty i czasu itp. Każdy z tych formatów możemy dodatkowo przystosowywać do naszych potrzeb […]

    Formatowanie niestandardowe w arkuszu kalkulacyjnym MS Excel

    Arkusz kalkulacyjne MS Excel oferuje nam szeroką gamę wbudowanych formatów standardowych takich jak: liczbowe, walutowe, księgowe, daty i czasu itp. Każdy z tych formatów możemy dodatkowo przystosowywać do naszych potrzeb […]

    Czytaj dalej...